Wind River Support Network

HomeOther Downloads

Other Downloads

Other downloads refer to patches, RCPLs, BSPs, drivers, service packs, sample codes, update packs, networking migration patches, and miscellaneous that are provided by Wind River.

Reset
Showing
of 1220 entries
NameTypeRequirementSummaryProductsRelease DateLast Modify Date
PowerPC 405 Architecture Support Patch Optional Add support to General Purpose Platform, Linux Edition 1.3 for the PowerPC 405 architecture. Linux Platforms 1.x Sep 20, 2006 Sep 20, 2006
Kernel High Res Timer Patch for Platform NE Linux Edition 1.4 Patch Optional Kernel High Resolution Timer Patch for FSL 8548 (Early Access) Linux Platforms 1.x Oct 31, 2006 Oct 31, 2006
PNE-LE 1.3 support for the ppc_603e CPU type Patch Recommended PNE support for the ppc_603e CPU type (target-libs, RPMS, and toolchain links). Linux Platforms 1.x Nov 9, 2006 Nov 9, 2006
Enhanced Carrier Grade Linux (ecgl) Patch Optional Provides ecgl carrier grade extensions for the standard Wind River Linux Carrier Grade Linux kernel Linux Platforms 1.x Dec 21, 2006 Dec 21, 2006
Fix for defect WIND00083483 Patch Recommended Fix to address the RT build failure issue in PCD-LE (reported in defect WIND00083483)

PXA 270 cannot build with with a small kernel and rt template.
Linux Platforms 1.x Jan 1, 2007 Jan 1, 2007
Fix for defect WIND00083478 Patch Optional MIPS32/64 KGDB corrupts the fpscr register when handling a memory fault. Linux Platforms 1.x Mar 12, 2007 Mar 12, 2007
Fix for defect WIND00084683 (for Wind River Linux 1.3) Patch Optional This patch addresses an issue reported for PNE-LE 1.3 (kexec does not work on intel_mpcbl0030 board).

Linux Platforms 1.x Apr 23, 2007 Apr 23, 2007
Fix for defect WIND00084683 (for Wind River Linux 1.4) Patch Optional This patch addresses an issue reported for PNE-LE 1.4 (kexec does not work on intel_mpcbl0030 board). Linux Platforms 1.x Apr 23, 2007 Apr 23, 2007
Fix for defect WIND00084958 (Bash should always be compiled with job control) Patch Optional This patch fixes the issue reported job control issue for bash on non-glibc_small root filesystems. Linux Platforms 1.x Apr 24, 2007 Apr 24, 2007
Fix for defect WIND00085801 Patch Optional dynamic loading of perl module causes segmentation fault Linux Platforms 1.x May 18, 2007 May 18, 2007
Fix for defect WIND00093265 Patch Optional Linux Kernel crashed on heavily loaded POSIX timer. Linux Platforms 1.x Jun 4, 2007 Jun 4, 2007
Fix for Defect WIND00089704 Patch Optional There needs to be a way to customize the resulting filesystem after rpm but before tar.bz2 phase Linux Platforms 1.x Jun 8, 2007 Jun 8, 2007
Linux Patches For OCD Support Patch Recommended Linux Patches For OCD Support Linux Platforms 1.x Jun 8, 2007 Jun 8, 2007
Fix for Defect WIND00095300 Patch Optional Bug in tar (GNU tar) 1.15.1 running on WR Linux 1.4 Linux Platforms 1.x Jun 8, 2007 Jun 8, 2007
ARM v5te Architecture Support Patch Optional Add support to Platform for Consumer Devices, Linux Edition 1.5 for the ARM v5te architecture. Linux Platforms 1.x Jul 10, 2007 Jul 10, 2007
Fix for the build error with the option --enable-build-libc=yes Patch Optional Fix for the build error with the option --enable-build-libc=yes Linux Platforms 1.x Aug 2, 2007 Aug 2, 2007
Patch to iptables to fix a "bad file descriptor" error. (for Wind River Linux 1.4) Patch Optional This patches iptables and fixes it from giving a "bad file descriptor" error. Linux Platforms 1.x Aug 5, 2007 Aug 5, 2007
Patch to iptables to fix a "bad file descriptor" error. (for Wind River Linux 1.5) Patch Optional This patches iptables and fixes it from giving a "bad file descriptor" error.
Linux Platforms 1.x Aug 5, 2007 Aug 5, 2007
Fix to SCTP to be able to connect and run when MTU size to 200. Patch Optional When setting MTU size to 200, SCTP application not able to connect and run. Linux Platforms 1.x Aug 17, 2007 Aug 17, 2007
Patch to the linux kernel that fixes a kernel crash under heavily loaded POSIX threads and timers. Patch Optional Patch to the linux kernel that fixes a kernel crash under heavily loaded POSIX threads and timers. Linux Platforms 1.x Sep 16, 2007 Sep 16, 2007
Patch to fix the preemptive kernel for fsl_mpc8349e_mitx BSP not to show "scheduling while atomic" message. Patch Optional Patch to fix the preemptive kernel for fsl_mpc8349e_mitx BSP not to show "scheduling while atomic" message. Linux Platforms 1.x Sep 16, 2007 Sep 16, 2007
Patch to Cavium Octeon build so that it does not fail when rb-pi-futex feature is enabled Patch Optional Patch to Cavium Octeon build so that it does not fail when rb-pi-futex feature is enabled Linux Platforms 1.x Sep 17, 2007 Sep 17, 2007
This is a fix to the e1000 driver 7.0.33-k2 in PNE-LE 1.4 fixing the significant packet loss Patch Optional This is a fix to the e1000 driver 7.0.33-k2 in PNE-LE 1.4 fixing the significant packet loss Linux Platforms 1.x Sep 24, 2007 Sep 24, 2007
Patch for Security Issue: Integer overflow in the get_fdb_entries function in net/bridge/br_ioctl.c - CVE-2006-5751 (for Wind River Linux 1.5) Patch Recommended Patch for Security Issue: Integer overflow in the get_fdb_entries function in net/bridge/br_ioctl.c - CVE-2006-5751 Linux Platforms 1.x Sep 25, 2007 Sep 25, 2007
Patch for the Security Issue: Linux Kernel - IPv6 Routing - CVE-2007-2242 (for Wind River Linux 1.5) Patch Recommended Patch for the Security Issue: Linux Kernel - IPv6 Routing - CVE-2007-2242 Linux Platforms 1.x Sep 25, 2007 Sep 25, 2007
Patch for the Security Issue: Linux Kernel - IPv6 Routing - CVE-2007-2242 (for Wind River Linux 1.3) Patch Recommended Patch for the Security Issue: Linux Kernel - IPv6 Routing - CVE-2007-2242 Linux Platforms 1.x Sep 27, 2007 Sep 27, 2007
Patch for the Security Issue: Linux Kernel - IPv6 Routing - CVE-2007-2242 (for Wind River Linux 1.4) Patch Recommended Patch for the Security Issue: Linux Kernel - IPv6 Routing - CVE-2007-2242 Linux Platforms 1.x Sep 27, 2007 Sep 27, 2007
Patch for Security Issue: Integer overflow in the get_fdb_entries function in net/bridge/br_ioctl.c - CVE-2006-5751 (for Wind River Linux 1.3) Patch Recommended Patch for Security Issue: Integer overflow in the get_fdb_entries function in net/bridge/br_ioctl.c - CVE-2006-5751 Linux Platforms 1.x Sep 27, 2007 Sep 27, 2007
Patch for Security Issue: Integer overflow in the get_fdb_entries function in net/bridge/br_ioctl.c - CVE-2006-5751 (for Wind River Linux 1.4) Patch Recommended Patch for Security Issue: Integer overflow in the get_fdb_entries function in net/bridge/br_ioctl.c - CVE-2006-5751 Linux Platforms 1.x Sep 27, 2007 Sep 27, 2007
Patch for a race condition, vsftpd fails to process PASV request from clients. Patch Optional Patch for a race condition, vsftpd fails to process PASV request from clients. Linux Platforms 1.x Oct 11, 2007 Oct 11, 2007
Fix to cavium Octeon board (CN38xx,...) to patch the kernel oops on system halt: system crash when synchronizing the RTC Patch Optional Fix to cavium Octeon board (CN38xx,...) to patch the kernel oops on system halt: system crash when synchronizing the RTC Linux Platforms 1.x Nov 27, 2007 Nov 27, 2007
Patch to make SysRq t work correctly on mpc_8349e_mitx. Patch Optional Patch to make SysRq t work correctly on mpc_8349e_mitx.
Fix applies to 1.5
Linux Platforms 1.x Mar 19, 2009 Nov 28, 2007
Patch to glibc that fixes the "glibc detected *** double free or corruption:" error when posix timer application is run. Patch Optional Patch to glibc that fixes the "glibc detected *** double free or corruption:" error when posix timer application is run. Linux Platforms 1.x Dec 9, 2007 Dec 9, 2007
Patch to the kernel to avoid posix timer test crashing the kernel. Patch Optional Patch to the kernel to avoid posix timer test crashing the kernel. Linux Platforms 1.x Dec 9, 2007 Dec 9, 2007
Fixing known vulenarbilities in OpenSSH in WRLinux1.2 Patch Recommended Fixing known vulenarbilities in OpenSSH in WRLinux1.2 Linux Platforms 1.x Jan 23, 2008 Jan 23, 2008
Patch to provide missing support for PAM in login Patch Optional Patch to provide missing support for PAM in login
Fix available for 1.4 and 1.5
Linux Platforms 1.x Jan 6, 2009 Jan 6, 2009
Fixes to security issues CVE-2006-1857 and CVE-2006-1858, Patch Recommended Fixes to security issues CVE-2006-1857 and CVE-2006-1858, Linux Platforms 1.x Jan 30, 2008 Jan 30, 2008
Fixes to security issues CVE-2006-1857 and CVE-2006-1858 Patch Recommended Fixes to security issues CVE-2006-1857 and CVE-2006-1858 Linux Platforms 1.x Jan 30, 2008 Jan 30, 2008
CVE-2008-0007 Security Fix Patch Recommended linux kernel - CVE-2008-0007
Fix available for 1.4 and 1.5
Linux Platforms 2.0 Mar 20, 2008 Mar 20, 2008
atftp package for PNE LE 2.0 Patch Optional atftp package for PNE LE 2.0 Linux Platforms 2.0 Mar 27, 2008 Mar 27, 2008
Service Pack 1 for Wind River Linux 2.0 Patch Recommended Click here to go to download page Linux Platforms 2.0 Apr 14, 2008 Apr 14, 2008
Security Advisory MySQL - CVE-2007-5925 Patch Recommended Security Advisory MySQL - CVE-2007-5925 Linux Platforms 1.x Apr 21, 2008 Apr 21, 2008
Buffer overflow in perl 5.8 - CVE-2007-5116 Patch Recommended Buffer overflow in perl 5.8 - CVE-2007-5116
Fix available 1.4, 1.5 & 2.0
Linux Platforms 2.0 Apr 22, 2008 Apr 22, 2008
Executing "make -C build postgresql" error. Patch Recommended report can't find tclConfig.sh and include directory for python isn't ok. Linux Platforms 2.0 Apr 23, 2008 Apr 23, 2008
krb5 - security advisory - CVE-2008-0948 Patch Recommended krb5 - security advisory - CVE-2008-0947 CVE-2008-0948 Linux Platforms 2.0 Apr 24, 2008 Apr 24, 2008
rsync before 3.0.0pre6 - CVE-2007-6199 Patch Recommended rsync before 3.0.0pre6 - CVE-2007-6199
Fix available for 1.4, 1.5 and 2.0
Linux Platforms 2.0 Apr 24, 2008 Apr 24, 2008
Apache-SSL fails to build on 64-bit host Patch Optional Apache-SSL fails to build on 64-bit host Linux Platforms 2.0 Apr 25, 2008 Apr 25, 2008
wrlinux 1.4 gnu 3.4.4 ICE Patch Optional This patch for wrlinux 1.4 gnu 3.4.4 ICE is available for 1.4 and 1.5 Linux Platforms 1.x Apr 25, 2008 Apr 25, 2008
Security Issue: ipsec-tools/racoon DoS - CVE-2007-184 Patch Optional Security Issue: ipsec-tools/racoon DoS - CVE-2007-184
Fix for 1.4 and 1.5
Linux Platforms 1.x Apr 25, 2008 Apr 25, 2008
Security advisory - libpng CVE-2007-5268 Patch Optional Security advisory - libpng CVE-2007-5268
Fix available for 1.4 and 1.5
Linux Platforms 1.x Apr 25, 2008 Apr 25, 2008
Live chat
Online