Wind River Support Network

HomeDefectsLIN8-2873
Fixed

LIN8-2873 : Security Advisory - nettle - CVE-2015-8805

Created: Feb 24, 2016    Updated: Dec 3, 2018
Resolved Date: Feb 29, 2016
Found In Version: 8.0
Fix Version: 8.0.0.3
Severity: Standard
Applicable for: Wind River Linux 8
Component/s: Userspace

Description

The ecc_256_modq function in ecc-256.c in Nettle before 3.2 does not properly handle carry propagation and produces incorrect output in its implementation of the P-256 NIST elliptic curve, which allows attackers to have unspecified impact via unknown vectors, a different vulnerability than CVE-2015-8803.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-8805

Other Downloads


CVEs


Live chat
Online