Wind River Support Network

HomeDefectsLIN10-3344
Fixed

LIN10-3344 : Security Advisory - glibc - CVE-2018-1000001

Created: Feb 27, 2018    Updated: Dec 3, 2018
Resolved Date: Jul 10, 2018
Found In Version: 10.17.41.1
Fix Version: 10.17.41.9
Severity: Standard
Applicable for: Wind River Linux LTS 17
Component/s: Toolchain

Description

In glibc 2.26 and earlier there is confusion in the usage of getcwd() by realpath() which can be used to write before the destination buffer leading to a buffer underflow and potential code execution.

https://nvd.nist.gov/vuln/detail/CVE-2018-1000001

Other Downloads


CVEs


Live chat
Online