Wind River Support Network

HomeOther DownloadsAdd support to Platform for Consumer Devices, Linux Edition 1.4 for the ARM926 Architecture without Vector Floating Point Processor (VFP)
Optional Type: Miscellaneous

Add support to Platform for Consumer Devices, Linux Edition 1.4 for the ARM926 Architecture without Vector Floating Point Processor (VFP)

Released: Oct 10, 2007     Updated: Oct 10, 2007

Description

PCD-LE 1.4 provides root filesystem support for the ARM926 architecture with VFP. This patch adds root filesystem support for the ARM926 architecture without VFP.


INSTALLATION PROCEDURE FOR LINUX HOST:

1) Shutdown Workbench 2.6 if running.

2) Update the Wind River Workbench 2.6 and ScopeTools installation to 2.6.1 using the following link:

https://portal.windriver.com/cgi-bin/windsurf/downloads/view_binary.cgi?binaryid=110040

3) Download the appropriate patch, then unpack it at the PCD-LE 1.4 installation directory (as user, not root):

$ cd {installdir}
$ tar zxpf wrl_1_4-pd-arm_novfp.tar.gz (for Platform Developer, Linux host)
or
$ tar zxpf wrl_1_4-ad-arm_novfp-for-x86-linux2.tar.gz (for Application Developer, Linux host)


INSTALLATION PROCEDURE FOR WINDOWS HOST:

1) Shutdown Workbench 2.6 if running.

2) Update the Wind River Workbench 2.6 and ScopeTools installation to 2.6.1 using the following link:

https://portal.windriver.com/cgi-bin/windsurf/downloads/view_binary.cgi?binaryid=110040

3) Download wrl_1_4-ad-arm_novfp-for-x86-win32.zip, then unzip it to the PCD-LE 1.4 installation directory. The unzip tool may ask your permission to replace 'scopetools.sh'. In that case please select YES to update 'scopetools.sh'.


USAGE:
Please specify arm_926soft as the cpu template for your BSP.

CAVEATS:
Scopetools are supported only for SMALL kernel with this patch. If you choose CGL kernel with glibc_std or glibc_small root filesystem, scopetools are not installed in the root filesystem.
IDENTIFIER = pcdle14_arm926_no_vfp


Product Version

Linux Platforms 1.x

Downloads


Live chat
Online