Wind River Support Network

HomeDefectsLIN1021-358
Fixed

LIN1021-358 : Security Advisory - curl - CVE-2021-22897

Created: May 26, 2021    Updated: Aug 24, 2021
Resolved Date: Aug 23, 2021
Found In Version: 10.21.20.1
Fix Version: 10.21.20.4
Severity: Standard
Applicable for: Wind River Linux LTS 21
Component/s: Userspace

Description

libcurl lets applictions specify which specific TLS ciphers to use in transfers, using the option called CURLOPT_SSL_CIPHER_LIST. The cipher selection is used for the TLS negotation when a transfer is done involving any of the TLS based transfer protocols libcurl supports, such as HTTPS, FTPS, IMAPS, POP3S, SMTPS etc.

https://curl.se/docs/CVE-2021-22897.html

CREATE(Triage):(User=admin) [CVE-2021-22897|https://nvd.nist.gov/vuln/detail/CVE-2021-22897]

CVEs


Live chat
Online