Wind River Support Network

HomeDefectsLIN1021-11
Fixed

LIN1021-11 : Security Advisory - linux - CVE-2020-24588 (WiFi)

Created: May 17, 2021    Updated: Aug 25, 2021
Resolved Date: Jul 12, 2021
Found In Version: 10.21.20.1
Fix Version: 10.21.20.1
Severity: Standard
Applicable for: Wind River Linux LTS 21
Component/s: Kernel

Description

The 802.11 standard that underpins Wi-Fi Protected Access (WPA, WPA2, and WPA3) and Wired Equivalent Privacy (WEP) doesn't require that the A-MSDU flag in the plaintext QoS header field is authenticated. Against devices that support receiving non-SSP A-MSDU frames (which is mandatory as part of 802.11n), an adversary can abuse this to inject arbitrary network packets.

CREATE(Triage):(User=admin) [CVE-2020-24588|https://nvd.nist.gov/vuln/detail/CVE-2020-24588]

CVEs


Live chat
Online