Wind River Support Network

HomeDefectsLIN1019-3827
Fixed

LIN1019-3827 : Security Advisory - php - CVE-2019-11050

Created: Dec 22, 2019    Updated: Jan 16, 2020
Resolved Date: Dec 31, 2019
Found In Version: 10.19.45.1
Fix Version: 10.19.45.3
Severity: Standard
Applicable for: Wind River Linux LTS 19
Component/s: Userspace

Description

When PHP EXIF extension is parsing EXIF information from an image, e.g. via exif_read_data() function, in PHP versions 7.2.x below 7.2.26, 7.3.x below 7.3.13 and 7.4.0 it is possible to supply it with data what will cause it to read past the allocated buffer. This may lead to information disclosure or crash.

CREATE(Triage):(User=admin) [CVE-2019-11050|https://nvd.nist.gov/vuln/detail/CVE-2019-11050]

CVEs


Live chat
Online