Wind River Support Network

HomeDefectsLIN1018-6265
Fixed

LIN1018-6265 : Security Advisory - python3-django - CVE-2019-14232

Created: Jun 4, 2020    Updated: Jun 21, 2020
Resolved Date: Jun 21, 2020
Found In Version: 10.18.44.1
Severity: Standard
Applicable for: Wind River Linux LTS 18
Component/s: Userspace

Description

An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. If django.utils.text.Truncator's chars() and words() methods were passed the html=True argument, they were extremely slow to evaluate certain inputs due to a catastrophic backtracking vulnerability in a regular expression. The chars() and words() methods are used to implement the truncatechars_html and truncatewords_html template filters, which were thus vulnerable.

CREATE(Triage):(User=admin) [CVE-2019-14232|https://nvd.nist.gov/vuln/detail/CVE-2019-14232]

CVEs


Live chat
Online