Wind River Support Network

HomeDefectsLIN1018-6237
Fixed

LIN1018-6237 : Security Advisory - vim - CVE-2019-20807

Created: May 31, 2020    Updated: Jul 14, 2020
Resolved Date: Jun 21, 2020
Found In Version: 10.18.44.1
Fix Version: 10.18.44.18
Severity: Standard
Applicable for: Wind River Linux LTS 18
Component/s: Userspace

Description

In Vim before 8.1.0881, users can circumvent the rvim restricted mode and execute arbitrary OS commands via scripting interfaces (e.g., Python, Ruby, or Lua).

CREATE(Triage):(User=admin) [CVE-2019-20807|https://nvd.nist.gov/vuln/detail/CVE-2019-20807]

CVEs


Live chat
Online