Wind River Support Network

HomeDefectsLIN1018-2957
Fixed

LIN1018-2957 : Security Advisory - ruby - CVE-2018-16395

Created: Nov 15, 2018    Updated: Mar 7, 2019
Resolved Date: Feb 21, 2019
Found In Version: unknown
Fix Version: 10.18.44.4
Severity: Standard
Applicable for: Wind River Linux LTS 18
Component/s: Userspace

Description

An instance of OpenSSL::X509::Name contains entities such as CN, C and so on. Some two instances of OpenSSL::X509::Name are equal only when all entities are exactly equal. However, there is a bug that the equality check is not correct if the value of an entity of the argument (right-hand side) starts with the value of the receiver (left-hand side). So, if a malicious X.509 certificate is passed to compare with an existing certificate, there is a possibility to be judged incorrectly that they are equal.

https://nvd.nist.gov/vuln/detail/CVE-2018-16395

CVEs


Live chat
Online