Wind River Support Network

Meet the Support Network

Home CVE Database CVE-2023-0286

CVE-2023-0286

Description

There is a type confusion vulnerability relating to X.400 address processing inside an X.509 GeneralName. X.400 addresses were parsed as an ASN1_STRING but the public structure definition for GENERAL_NAME incorrectly specified the type of the x400Address field as ASN1_TYPE. This field is subsequently interpreted by the OpenSSL function GENERAL_NAME_cmp as an ASN1_TYPE rather than an ASN1_STRING. When CRL checking is enabled (i.e. the application sets the X509_V_FLAG_CRL_CHECK flag), this vulnerability may allow an attacker to pass arbitrary pointers to a memcmp call, enabling them to read memory contents or enact a denial of service. In most cases, the attack requires the attacker to provide both the certificate chain and CRL, neither of which need to have a valid signature. If the attacker only controls one of these inputs, the other input must already contain an X.400 address as a CRL distribution point, which is uncommon. As such, this vulnerability is most likely to only affect applications which have implemented their own functionality for retrieving CRLs over a network.

Priority: LOW
CVSS v3: 7.4
Component: openssl
Publish Date: Feb 8, 2023
Related ID: --
CVSS v2: HIGH
Modified Date: Feb 9, 2023

Find out more about CVE-2023-0286 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Requires LTSS -- -- --
Wind River Linux 8 Requires LTSS -- -- --
Wind River Linux 9 Requires LTSS -- -- --
Wind River Linux 7 Requires LTSS -- -- --
Wind River Linux LTS 21 Fixed LIN1021-5206
10.21.20.17 --
Wind River Linux LTS 22 Fixed LIN1022-3291
10.22.33.7 --
Wind River Linux LTS 18 Fixed LIN1018-10318
10.18.44.29 --
Wind River Linux LTS 19 Fixed LIN1019-9416
10.19.45.27 --
Wind River Linux CD release Fixed LINCD-11683
10.23.9.0 --
Wind River Linux 6 Requires LTSS -- -- --
Wind River Linux LTS 23 Not Vulnerable -- -- --
VxWorks
VxWorks 7 Fixed -- 23.03 --
VxWorks 6.9 Fixed -- 6.9.4.12 RCPL7 --
Helix Virtualization Platform Cert Edition
Helix Virtualization Platform Cert Edition Vulnerable -- -- --
eLxr
eLxr 12 Not Vulnerable -- -- --

Related Products

Product Name Status Defect Fixed Downloads

Notes
Requires LTSS - customers must have active LTSS (Long Term Security Shield) Support to receive up-to-date information about vulnerabilities that may affect legacy software. Please contact your Wind River account team or see https://docs.windriver.com/bundle/Support_and_Maintenance_Supplemental_Terms_and_Conditions and https://support2.windriver.com/index.php?page=plc for more information.
Live chat
Online