Wind River Support Network

Meet the Support Network

Home CVE Database CVE-2022-33099

CVE-2022-33099

Description

An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.

Priority: MEDIUM
CVSS v3: 7.5
Component: lua
Publish Date: Jul 1, 2022
Related ID: --
CVSS v2: HIGH
Modified Date: Jul 1, 2022

Find out more about CVE-2022-33099 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Fixed LIN10-10303
10.17.41.27 --
Wind River Linux 8 Requires LTSS -- -- --
Wind River Linux 9 Requires LTSS -- -- --
Wind River Linux 7 Requires LTSS -- -- --
Wind River Linux LTS 21 Investigate -- -- --
Wind River Linux LTS 18 Fixed LIN1018-9474
10.18.44.27 --
Wind River Linux LTS 19 Fixed LIN1019-8530
10.19.45.24 --
Wind River Linux CD release Fixed -- 10.22.33.0 --
VxWorks
VxWorks 7 Not Vulnerable -- -- --
VxWorks 6.9 Not Vulnerable -- -- --

Related Products

Product Name Status Defect Fixed Downloads

Notes
Requires LTSS - customers must have active LTSS (Long Term Security Shield) Support to receive up-to-date information about vulnerabilities that may affect legacy software. Please contact your Wind River account team or see https://docs.windriver.com/bundle/Support_and_Maintenance_Supplemental_Terms_and_Conditions and https://support2.windriver.com/index.php?page=plc for more information.
Live chat
Online