Wind River Support Network

Meet the Support Network

Home CVE Database CVE-2022-22824

CVE-2022-22824

Description

defineAttribute in xmlparse.c in Expat (aka libexpat) before 2.4.3 has an integer overflow.

Priority: HIGH
CVSS v3: 9.8
Component: expat
Publish Date: Jan 9, 2022
Related ID: --
CVSS v2: CRITICAL
Modified Date: Jan 9, 2022

Find out more about CVE-2022-22824 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Fixed LIN10-9482
10.17.41.26 --
Wind River Linux 8 Requires LTSS -- -- --
Wind River Linux 9 Requires LTSS -- -- --
Wind River Linux 7 Requires LTSS -- -- --
Wind River Linux LTS 21 Fixed LIN1021-2363
10.21.20.10 --
Wind River Linux LTS 18 Fixed LIN1018-8585
10.18.44.25 --
Wind River Linux LTS 19 Fixed LIN1019-7628
10.19.45.22 --
Wind River Linux CD release Not Vulnerable -- -- --
VxWorks
VxWorks 7 Fixed -- 22.06 --
VxWorks 6.9 Vulnerable -- -- --

Related Products

Product Name Status Defect Fixed Downloads

Notes
Requires LTSS - customers must have active LTSS (Long Term Security Shield) Support to receive up-to-date information about vulnerabilities that may affect legacy software. Please contact your Wind River account team or see https://docs.windriver.com/bundle/Support_and_Maintenance_Supplemental_Terms_and_Conditions and https://support2.windriver.com/index.php?page=plc for more information.
Live chat
Online