Wind River Support Network

Meet the Support Network

Home CVE Database CVE-2022-22707

CVE-2022-22707

Description

In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.

Priority: MEDIUM
CVSS v3: 5.9
Component: lighttpd
Publish Date: Jan 6, 2022
Related ID: --
CVSS v2: MEDIUM
Modified Date: Jan 6, 2022

Find out more about CVE-2022-22707 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Not Vulnerable -- -- --
Wind River Linux 8 Requires LTSS -- -- --
Wind River Linux 9 Requires LTSS -- -- --
Wind River Linux 7 Requires LTSS -- -- --
Wind River Linux LTS 21 Fixed LIN1021-2357
10.21.20.11 --
Wind River Linux LTS 18 Fixed LIN1018-8581
10.18.44.25 --
Wind River Linux LTS 19 Fixed LIN1019-7623
10.19.45.21 --
Wind River Linux CD release Fixed -- 10.21.48.0 --
VxWorks
VxWorks 7 Not Vulnerable -- -- --
VxWorks 6.9 Not Vulnerable -- -- --

Related Products

Product Name Status Defect Fixed Downloads

Notes
Requires LTSS - customers must have active LTSS (Long Term Security Shield) Support to receive up-to-date information about vulnerabilities that may affect legacy software. Please contact your Wind River account team or see https://docs.windriver.com/bundle/Support_and_Maintenance_Supplemental_Terms_and_Conditions and https://support2.windriver.com/index.php?page=plc for more information.
Live chat
Online