Home CVE Database CVE-2021-23840

CVE-2021-23840

Description

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Priority: MEDIUM
CVSS v3: 7.5
Publish Date: Feb 16, 2021
Related ID: --
CVSS v2: HIGH
Modified Date: Feb 19, 2021

Find out more about CVE-2021-23840 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Fixed LIN10-8264
10.17.41.24 --
Wind River Linux 8 Legacy -- -- --
Wind River Linux 9 Legacy -- -- --
Wind River Linux 7 Legacy -- -- --
Wind River Linux LTS 21 Fixed -- 10.19.45.17 --
Wind River Linux LTS 18 Fixed LIN1018-7276
10.18.44.22 --
Wind River Linux LTS 19 Fixed LIN1019-6079
10.19.45.17 --
Wind River Linux CD release Not Vulnerable -- -- --
VxWorks
VxWorks 7 Fixed -- 21.03 --
VxWorks 6.9 Fixed -- 6.9.4.12 RCPL3 --

Related Products

Product Name Status Defect Fixed Downloads

Comments

openssl

Live chat
Online