Home CVE Database CVE-2020-9402

CVE-2020-9402

Description

Django 1.11 before 1.11.29, 2.2 before 2.2.11, and 3.0 before 3.0.4 allows SQL Injection if untrusted data is used as a tolerance parameter in GIS functions and aggregates on Oracle. By passing a suitably crafted tolerance to GIS functions and aggregates on Oracle, it was possible to break escaping and inject malicious SQL.

Priority: HIGH
CVSS v3: 9.8
Publish Date: Mar 5, 2020
Related ID: --
CVSS v2: CRITICAL
Modified Date: Mar 10, 2020

Find out more about CVE-2020-9402 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Fixed LIN10-7399
10.17.41.21 --
Wind River Linux 8 Requires LTSS -- -- --
Wind River Linux 9 Fixed LIN9-10002
9.0.0.26 --
Wind River Linux 7 Requires LTSS -- -- --
Wind River Linux LTS 21 Fixed -- 10.21.20.1 --
Wind River Linux LTS 18 Fixed LIN1018-6272
10.18.44.18 --
Wind River Linux LTS 19 Fixed LIN1019-4787
10.19.45.9 --
Wind River Linux CD release Fixed LINCD-2214
10.20.27.0 --
VxWorks
VxWorks 7 Not Vulnerable -- -- --
VxWorks 6.9 Not Vulnerable -- -- --

Related Products

Product Name Status Defect Fixed Downloads

Comments

python-django&python3-django


Notes
Requires LTSS - customers must have active LTSS (Long Term Security Shield) Support to receive up-to-date information about vulnerabilities that may affect legacy software. Please contact your Wind River account team or see https://docs.windriver.com/bundle/Support_and_Maintenance_Supplemental_Terms_and_Conditions and https://support2.windriver.com/index.php?page=plc for more information.
Live chat
Online