Home CVE Database CVE-2019-9956

CVE-2019-9956

Description

In ImageMagick 7.0.8-35 Q16, there is a stack-based buffer overflow in the function PopHexPixel of coders/ps.c, which allows an attacker to cause a denial of service or code execution via a crafted image file.

Priority: LOW
CVSS v3: 8.8
Publish Date: Mar 23, 2019
Related ID: --
CVSS v2: HIGH
Modified Date: Mar 27, 2019

Find out more about CVE-2019-9956 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Won't Fix -- -- --
Wind River Linux 9 Fixed LIN9-8264
9.0.0.21 --
Wind River Linux 8 Fixed LIN8-10669
8.0.0.30 --
Wind River Linux 7 Fixed LIN7-10800
7.0.0.30 --
Wind River Linux LTS 18 Won't Fix -- -- --
VxWorks
VxWorks 7 Not Vulnerable -- -- --
VxWorks 6.9 Not Vulnerable -- -- --
VxWorks 6.8 Not Vulnerable -- -- --
VxWorks 6.7 Not Vulnerable -- -- --
VxWorks 6.6 Not Vulnerable -- -- --
VxWorks 6.4 Not Vulnerable -- -- --
VxWorks 5.5 Not Vulnerable -- -- --

Related Products

Product name Status
Linux
Linux 7 SCP Not Vulnerable
Linux 7 CGP Not Vulnerable

Comments

imagemagick

Live chat
Online