Home CVE Database CVE-2018-5711

CVE-2018-5711

Description

gd_gif_in.c in the GD Graphics Library (aka libgd), as used in PHP before 5.6.33, 7.0.x before 7.0.27, 7.1.x before 7.1.13, and 7.2.x before 7.2.1, has an integer signedness error that leads to an infinite loop via a crafted GIF file, as demonstrated by a call to the imagecreatefromgif or imagecreatefromstring PHP function. This is related to GetCode_ and gdImageCreateFromGifCtx.

Priority: MEDIUM
CVSS v3: 5.5
Publish Date: Jan 16, 2018
Related ID: --
CVSS v2: MEDIUM
Modified Date: Jan 16, 2018

Find out more about CVE-2018-5711 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

libgd&php

Live chat
Online