Home CVE Database CVE-2018-5381

CVE-2018-5381

Description

The Quagga BGP daemon (bgpd) prior to version 1.2.3 has a bug in its parsing of Capabilities in BGP OPEN messages, in the bgp_packet.c:bgp_capability_msg_parse function. The parser can enter an infinite loop on invalid capabilities if a Multi-Protocol capability does not have a recognized AFI/SAFI, causing a denial of service.

Priority: MEDIUM
CVSS v3: 7.5
Publish Date: Feb 19, 2018
Related ID: --
CVSS v2: HIGH
Modified Date: Feb 20, 2018

Find out more about CVE-2018-5381 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

quagga

Live chat
Online