Home CVE Database CVE-2018-18309

CVE-2018-18309

Description

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. An invalid memory address dereference was discovered in read_reloc in reloc.c. The vulnerability causes a segmentation fault and application crash, which leads to denial of service, as demonstrated by objdump, because of missing _bfd_clear_contents bounds checking.

Priority: MEDIUM
CVSS v3: 5.5
Publish Date: Oct 14, 2018
Related ID: --
CVSS v2: MEDIUM
Modified Date: Oct 14, 2018

Find out more about CVE-2018-18309 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

binutils

Live chat
Online