Home CVE Database CVE-2018-16842

CVE-2018-16842

Description

curl contains a heap out of buffer read vulnerability. The command line tool has a generic function for displaying warning and informational messages to stderr for various situations. For example if an unknown command line argument is used, or passed to it in a \"config\" file. This display function formats the output to wrap at 80 columns. The wrap logic is however flawed, so if a single word in the message is itself longer than 80 bytes the buffer arithmetic calculates the remainder wrong and will end up reading behind the end of the buffer. This could lead to information disclosure or crash.

Priority: MEDIUM
CVSS v3: 9.1
Publish Date: Oct 31, 2018
Related ID: --
CVSS v2: CRITICAL
Modified Date: Oct 31, 2018

Find out more about CVE-2018-16842 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

curl

Live chat
Online