Home CVE Database CVE-2018-14659

CVE-2018-14659

Description

The Gluster file system through versions 4.1.4 and 3.1.2 is vulnerable to a denial of service attack via use of the \'GF_XATTR_IOSTATS_DUMP_KEY\' xattr. A remote, authenticated attacker could exploit this by mounting a Gluster volume and repeatedly calling \'setxattr(2)\' to trigger a state dump and create an arbitrary number of files in the server\'s runtime directory.

Priority: MEDIUM
CVSS v3: 6.5
Publish Date: Oct 31, 2018
Related ID: --
CVSS v2: MEDIUM
Modified Date: Nov 6, 2018

Find out more about CVE-2018-14659 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

glusterfs

Live chat
Online