Home CVE Database CVE-2018-10907

CVE-2018-10907

Description

It was found that glusterfs server is vulnerable to multiple stack based buffer overflows due to functions in server-rpc-fopc.c allocating fixed size buffers using \'alloca(3)\'. An authenticated attacker could exploit this by mounting a gluster volume and sending a string longer that the fixed buffer size to cause crash or potential code execution.

Priority: MEDIUM
CVSS v3: 8.8
Publish Date: Sep 4, 2018
Related ID: --
CVSS v2: HIGH
Modified Date: Sep 5, 2018

Find out more about CVE-2018-10907 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

glusterfs

Live chat
Online