Home CVE Database CVE-2018-10904

CVE-2018-10904

Description

It was found that glusterfs server does not properly sanitize file paths in the trusted.io-stats-dump extended attribute which is used by the debug/io-stats translator. Attacker can use this flaw to create files and execute arbitrary code. To exploit this attacker would require sufficient access to modify the extended attributes of files on a gluster volume.

Priority: MEDIUM
CVSS v3: 8.8
Publish Date: Sep 4, 2018
Related ID: --
CVSS v2: HIGH
Modified Date: Sep 5, 2018

Find out more about CVE-2018-10904 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

glusterfs

Live chat
Online