Home CVE Database CVE-2018-1000301

CVE-2018-1000301

Description

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

Priority: MEDIUM
CVSS v3: 9.1
Publish Date: May 24, 2018
Related ID: --
CVSS v2: CRITICAL
Modified Date: May 25, 2018

Find out more about CVE-2018-1000301 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

curl

Live chat
Online