Home CVE Database CVE-2017-9955

CVE-2017-9955

Description

The get_build_id function in opncls.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.28, allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file in which a certain size field is larger than a corresponding data field, as demonstrated by mishandling within the objdump program.

Priority: MEDIUM
CVSS v3: 5.5
Publish Date: Jun 26, 2017
Related ID: --
CVSS v2: Medium
Modified Date: Jun 26, 2017

Find out more about CVE-2017-9955 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

binutils

Live chat
Online