Home CVE Database CVE-2017-7895

CVE-2017-7895

Description

The NFSv2 and NFSv3 server implementations in the Linux kernel through 4.10.13 lack certain checks for the end of a buffer, which allows remote attackers to trigger pointer-arithmetic errors or possibly have unspecified other impact via crafted requests, related to fs/nfsd/nfs3xdr.c and fs/nfsd/nfsxdr.c.

Priority: HIGH
CVSS v3: 9.8
Publish Date: Apr 28, 2017
Related ID: --
CVSS v2: Critical
Modified Date: May 11, 2017

Find out more about CVE-2017-7895 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Won't Fix -- -- --
Wind River Linux 8 Fixed LIN8-6685
8.0.0.18 --
Wind River Linux 9 Fixed LIN9-4204
9.0.0.7 --
Wind River Linux 7 Fixed -- 7.0.0.26 --
Wind River Linux LTS 18 Won't Fix -- -- --
Wind River Linux LTS 19 Won't Fix -- -- --
Wind River Linux CD release Won't Fix -- -- --
VxWorks
VxWorks 7 Not Vulnerable -- -- --
VxWorks 6.9 Not Vulnerable -- -- --

Related Products

Product Name Status Defect Fixed Downloads

Comments

linux

Live chat
Online