Home CVE Database CVE-2017-7302

CVE-2017-7302

Description

The Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.28, has a swap_std_reloc_out function in bfd/aoutx.h that is vulnerable to an invalid read (of size 4) because of missing checks for relocs that could not be recognised. This vulnerability causes Binutils utilities like strip to crash.

Priority: MEDIUM
CVSS v3: 7.5
Publish Date: Mar 29, 2017
Related ID: --
CVSS v2: High
Modified Date: Mar 31, 2017

Find out more about CVE-2017-7302 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

binutils

Live chat
Online