Home CVE Database CVE-2017-18266

CVE-2017-18266

Description

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Priority: MEDIUM
CVSS v3: 8.8
Publish Date: May 10, 2018
Related ID: --
CVSS v2: HIGH
Modified Date: May 10, 2018

Find out more about CVE-2017-18266 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

xdg-utils

Live chat
Online