Home CVE Database CVE-2017-15670

CVE-2017-15670

Description

The GNU C Library (aka glibc or libc6) before 2.27 contains an off-by-one error leading to a heap-based buffer overflow in the glob function in glob.c, related to the processing of home directories using the ~ operator followed by a long string.

Priority: High
CVSS v3: 9.8
Publish Date: Oct 20, 2017
Related ID: --
CVSS v2: Critical
Modified Date: Oct 24, 2017

Find out more about CVE-2017-15670 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

glibc

Live chat
Online