Home CVE Database CVE-2017-14867

CVE-2017-14867

Description

Git before 2.10.5, 2.11.x before 2.11.4, 2.12.x before 2.12.5, 2.13.x before 2.13.6, and 2.14.x before 2.14.2 uses unsafe Perl scripts to support subcommands such as cvsserver, which allows attackers to execute arbitrary OS commands via shell metacharacters in a module name. The vulnerable code is reachable via git-shell even without CVS support.

Priority: HIGH
CVSS v3: 8.8
Publish Date: Sep 28, 2017
Related ID: --
CVSS v2: High
Modified Date: Sep 30, 2017

Find out more about CVE-2017-14867 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

git

Live chat
Online