Home CVE Database CVE-2017-12837

CVE-2017-12837

Description

Heap-based buffer overflow in the regular expression compiler in PERL before 5.24.3-RC1 and 5.26.x before 5.26.1-RC1 allows remote attackers to cause a denial of service (crash) via a crafted regular expression with the case-insensitive modifier.

Priority: MEDIUM
CVSS v3: 7.5
Publish Date: Sep 19, 2017
Related ID: --
CVSS v2: High
Modified Date: Sep 19, 2017

Find out more about CVE-2017-12837 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

perl

Live chat
Online