Home CVE Database CVE-2017-11144

CVE-2017-11144

Description

In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, the openssl extension PEM sealing code did not check the return value of the OpenSSL sealing function, which could lead to a crash of the PHP interpreter, related to an interpretation conflict for a negative number in ext/openssl/openssl.c, and an OpenSSL documentation omission.

Priority: MEDIUM
CVSS v3: 7.5
Publish Date: Jul 10, 2017
Related ID: --
CVSS v2: High
Modified Date: Jul 10, 2017

Find out more about CVE-2017-11144 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Not Vulnerable -- -- --
Wind River Linux 8 Fixed LIN8-7105
8.0.0.20 --
Wind River Linux 9 Fixed LIN9-4664
9.0.0.9 --
Wind River Linux 7 Fixed -- 7.0.0.26 --
Wind River Linux LTS 18 Not Vulnerable -- -- --
Wind River Linux LTS 19 Not Vulnerable -- -- --
Wind River Linux CD release Not Vulnerable -- -- --
VxWorks
VxWorks 7 Not Vulnerable -- -- --
VxWorks 6.9 Not Vulnerable -- -- --

Related Products

Product Name Status Defect Fixed Downloads

Comments

php

Live chat
Online