Wind River Support Network

Meet the Support Network

Home CVE Database CVE-2016-9586

CVE-2016-9586

Description

curl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl\'s implementation of the printf() functions. If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.

Priority: MEDIUM
CVSS v3: 8.1
Component: libcurl
Publish Date: Jan 11, 2017
Related ID: --
CVSS v2: HIGH
Modified Date: Jan 11, 2017

Find out more about CVE-2016-9586 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Not Vulnerable -- -- --
Wind River Linux 8 Fixed LIN8-5487
8.0.0.13 --
Wind River Linux 9 Fixed LIN9-2902
9.0.0.4 --
Wind River Linux 7 Fixed -- 7.0.0.23 --
Wind River Linux LTS 21 Not Vulnerable -- -- --
Wind River Linux LTS 18 Not Vulnerable -- -- --
Wind River Linux LTS 19 Not Vulnerable -- -- --
Wind River Linux CD release Not Vulnerable -- -- --
VxWorks
VxWorks 7 Fixed -- webcli_curl-7.55.1.0 --
VxWorks 6.9 Vulnerable -- -- --

Related Products

Product Name Status Defect Fixed Downloads

Notes
Requires LTSS - customers must have active LTSS (Long Term Security Shield) Support to receive up-to-date information about vulnerabilities that may affect legacy software. Please contact your Wind River account team or see https://docs.windriver.com/bundle/Support_and_Maintenance_Supplemental_Terms_and_Conditions and https://support2.windriver.com/index.php?page=plc for more information.
Live chat
Online