Home CVE Database CVE-2016-2390

CVE-2016-2390

Description

The FwdState::connectedToPeer method in FwdState.cc in Squid before 3.5.14 and 4.0.x before 4.0.6 does not properly handle SSL handshake errors when built with the --with-openssl option, which allows remote attackers to cause a denial of service (application crash) via a plaintext HTTP message.

Priority: MEDIUM
CVSS v3: 5.9
Publish Date: Apr 19, 2016
Related ID: --
CVSS v2: Medium
Modified Date: Apr 22, 2016

Find out more about CVE-2016-2390 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

squid

Live chat
Online