Home CVE Database CVE-2016-2226

CVE-2016-2226

Description

A vulnerability was found in gcc. Specifically, it revolves around demangling while analysing the untrusted binaries. A particularly malicious attacker could craft an executable that executes when *analysed* by objdump, nm or gdb, or any other libbfd / libiberty - based forensics tool (if the demangling option is switched on).

Priority: MEDIUM
CVSS v3: 7.8
Publish Date: May 29, 2016
Related ID: --
CVSS v2: High
Modified Date: May 29, 2016

Find out more about CVE-2016-2226 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Not Vulnerable -- -- --
Linux 7 CGP Not Vulnerable -- -- --

Comments

gcc

Live chat
Online