Home CVE Database CVE-2016-2177

CVE-2016-2177

Description

OpenSSL through 1.0.2h incorrectly uses pointer arithmetic for heap-buffer boundary checks, which might allow remote attackers to cause a denial of service (integer overflow and application crash) or possibly have unspecified other impact by leveraging unexpected malloc behavior, related to s3_srvr.c, ssl_sess.c, and t1_lib.c.CWE-190: Integer Overflow or Wraparound

Priority: HIGH
CVSS v3: 9.8
Publish Date: Jun 19, 2016
Related ID: --
CVSS v2: Critical
Modified Date: Jun 21, 2016

Find out more about CVE-2016-2177 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Not Vulnerable -- -- --
Wind River Linux 8 Fixed LIN8-3951
8.0.0.7 --
Wind River Linux 9 Not Vulnerable -- -- --
Wind River Linux 7 Fixed -- 7.0.0.17 --
Wind River Linux LTS 21 Not Vulnerable -- -- --
Wind River Linux LTS 18 Not Vulnerable -- -- --
Wind River Linux LTS 19 Not Vulnerable -- -- --
Wind River Linux CD release Not Vulnerable -- -- --
VxWorks
VxWorks 7 Fixed -- openSSL-1.1.0.0 --
VxWorks 6.9 Fixed -- 6.9.4.9 --

Related Products

Product Name Status Defect Fixed Downloads

Comments

openssl

Live chat
Online