Home CVE Database CVE-2016-2107

CVE-2016-2107

Description

The AES-NI implementation in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h does not consider memory allocation during a certain padding check, which allows remote attackers to obtain sensitive cleartext information via a padding-oracle attack against an AES CBC session, NOTE: this vulnerability exists because of an incorrect fix for CVE-2013-0169.

Priority: LOW
CVSS v3: 5.9
Publish Date: May 4, 2016
Related ID: --
CVSS v2: Medium
Modified Date: May 6, 2016

Find out more about CVE-2016-2107 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Not Vulnerable -- -- --
Wind River Linux 8 Fixed LIN8-3421
8.0.0.6 --
Wind River Linux 9 Fixed -- 9.0.0.0 --
Wind River Linux 7 Fixed -- 7.0.0.16 --
Wind River Linux LTS 21 Not Vulnerable -- -- --
Wind River Linux LTS 18 Not Vulnerable -- -- --
Wind River Linux LTS 19 Not Vulnerable -- -- --
Wind River Linux CD release Not Vulnerable -- -- --
VxWorks
VxWorks 7 Fixed V7SEC-202
openSSL-1.0.7.0 --
VxWorks 6.9 Fixed -- 6.9.4.9 --

Related Products

Product Name Status Defect Fixed Downloads

Comments

openssl

Live chat
Online