Home CVE Database CVE-2016-0705

CVE-2016-0705

Description

Double free vulnerability in the dsa_priv_decode function in crypto/dsa/dsa_ameth.c in OpenSSL 1.0.1 before 1.0.1s and 1.0.2 before 1.0.2g allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a malformed DSA private key.CWE-415: Double Free

Priority: HIGH
CVSS v3: 9.8
Publish Date: Mar 3, 2016
Related ID: --
CVSS v2: Critical
Modified Date: Mar 7, 2016

Find out more about CVE-2016-0705 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Not Vulnerable -- -- --
Wind River Linux 8 Fixed LIN8-2886
8.0.0.3 --
Wind River Linux 9 Fixed -- 9.0.0.0 --
Wind River Linux 7 Fixed -- 7.0.0.14 --
Wind River Linux LTS 21 Not Vulnerable -- -- --
Wind River Linux LTS 18 Not Vulnerable -- -- --
Wind River Linux LTS 19 Not Vulnerable -- -- --
Wind River Linux CD release Not Vulnerable -- -- --
VxWorks
VxWorks 7 Fixed V7SEC-202
openSSL-1.0.7.0 --
VxWorks 6.9 Fixed VXW6-85377
6.9.4.8 Wind River VxWorks 20160301 Security Alert for openssl
VxWorks 6.9 source patch for Defect VXW6-85377
Service Pack 8 for VxWorks 6.9.4 and VxWorks Edition 6.9.4 Platforms

Related Products

Product Name Status Defect Fixed Downloads

Comments

openssl


Notes
Requires LTSS - customers must have active LTSS (Long Term Security Shield) Support to receive up-to-date information about vulnerabilities that may affect legacy software. Please contact your Wind River account team or see https://docs.windriver.com/bundle/Support_and_Maintenance_Supplemental_Terms_and_Conditions and https://support2.windriver.com/index.php?page=plc for more information.
Live chat
Online