Home CVE Database CVE-2014-9670

CVE-2014-9670

Description

Multiple integer signedness errors in the pcf_get_encodings function in pcf/pcfread.c in FreeType before 2.5.4 allow remote attackers to cause a denial of service (integer overflow, NULL pointer dereference, and application crash) via a crafted PCF file that specifies negative values for the first column and first row.

Priority: LOW
CVSS v3: 0.0
Publish Date: Feb 8, 2015
Related ID: --
CVSS v2: 5.0
Modified Date: Feb 9, 2015

Find out more about CVE-2014-9670 from the MITRE-CVE dictionary and NIST NVD


Products Affected

Login may be required to access defects or downloads.

Product Name Status Defect Fixed Downloads
Linux
Wind River Linux LTS 17 Not Vulnerable -- -- Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2
Wind River Linux 9 Not Vulnerable -- -- Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2
Wind River Linux 8 Fixed -- 8.0.0.0 Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2
Wind River Linux LTS 18 Not Vulnerable -- -- Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2
Wind River Linux LTS 19 Not Vulnerable -- -- Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2
Wind River Linux CD release Not Vulnerable -- -- Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2
VxWorks
VxWorks 7 Fixed -- SR0640 Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2
VxWorks 6.9 Won't Fix -- -- Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2

Related Products

Product Name Status Defect Fixed Downloads
Linux 7 SCP Investigate -- -- Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2
Linux 7 CGP Investigate -- -- Wind River VxWorks Security Alert CVE-2014-9670 for FreeType 2

Comments

freetype

Live chat
Online