Wind River Support Network

HomeDefectsLIN5-9828
Fixed

LIN5-9828 : Security Advisory - libxi - CVE-2013-1998

Created: Jun 30, 2013    Updated: Dec 19, 2017
Resolved Date: Jul 15, 2014
Previous ID: LIN4-15288
Found In Version: 5.0.1.17
Fix Version: 5.0.1.17
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Multiple buffer overflows in X.org libXi 1.7.1 and earlier allow X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the (1) XGetDeviceButtonMapping, (2) XIPassiveGrabDevice, and (3) XQueryDeviceState functions.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-1998

Workaround

Unknown

Steps to Reproduce

Unknown

Other Downloads


Live chat
Online