Wind River Support Network

HomeDefectsLIN5-7161
Fixed

LIN5-7161 : fsl_p4080 BSP- 10G ethernet interface no longer comes up properly (regression from WRL 4.3)

Created: May 31, 2013    Updated: Dec 19, 2017
Resolved Date: Aug 20, 2013
Found In Version: 5.0.1
Fix Version: 5.0.1.7
Severity: Severe
Applicable for: Wind River Linux 5
Component/s: BSP

Description

When a project is built using WRL5.0.1 and the fsl_4080 BSP, the 10G ethernet does not come up on the target even though the README file states that it is supported.

This feature worked properly in WRL 4.3.

Steps to Reproduce

1.) build a project:
   a.) configure --enable-board=fsl_p4080 --enable-kernel=standard --enable-rootfs=glibc_small --enable-bootimage=flash --enable-jobs=4 --enable-parallel-pkgbuilds=2

   b.) make fs
   c.) ./scripts/fakestart.sh ./host-cross/bin/genext2fs --number-of-inodes 8000 -b 80000 -d export/dist initrd
   d.) gzip -f --best initrd
   e.) ./host-cross/bin/mkimage -A powerpc -O linux -T ramdisk -C gzip -d initrd.gz initrd.gz.uboot

2.) boot the generated files
   - fsl_p4080-p4080ds_36b.dtb-WR4.3.0.0_standard
   - fsl_p4080-uImage-WR4.3.0.0_standard
   - initrd.gz.uboot

3.) Verify no IP address on eth2
   - ifconfig -a

4.) Setup  an ip address on eth2
   - ifconfig eth2  10.40.201.105

5.) Turn off eth0 so eth2 is the only working connection 
   - ifconfig eth0  down

6.) Verify pinging the ip address on the other end of the 10G network
   - ping 10.40.201.102

Other Downloads


Live chat
Online