Wind River Support Network

HomeDefectsLIN5-476
Fixed

LIN5-476 : nearbyintl has wrong version listed in libm.so.6

Created: Feb 5, 2013    Updated: Dec 19, 2017
Resolved Date: May 14, 2013
Found In Version: 5.0.1
Fix Version: 5.0.1.4
Severity: Severe
Applicable for: Wind River Linux 5
Component/s: Toolchain

Description

The LSB tests for exported symbols don't find "nearbyintl (GLIBC_2.1)" on PowerPC targets, because it's misidentified as being (GLIBC_2.0) in libm.so. Programs that don't specify a version should work anyway.

Workaround

Don't specify the exact symbol version.

Steps to Reproduce

Build a project, add LSB, run the LSB tests.

Other Downloads


Live chat
Online