Wind River Support Network

HomeDefectsLIN5-3980
Fixed

LIN5-3980 : wrlinux 5.0.1 - adding xz to RDEPENDS of grub will pull in all xz binaries which is not expected to be

Created: Dec 18, 2013    Updated: Dec 19, 2017
Resolved Date: Dec 25, 2013
Found In Version: 5.0.1
Fix Version: 5.0.1.11
Severity: Severe
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

root@qemu18:~# rpm -q --requires grub
diffutils
liblzma5 >= 5.1.1alpha
libfreetype6
libc6 >= 2.15
/bin/sh
rtld(GNU_HASH)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
liblzma.so.5()(64bit)

Seemingly only liblzma5 is requiring by grub.

Steps to Reproduce

1 build a project with grub
2 make start-target
3 checkout the xz binaries

Other Downloads


Live chat
Online