Wind River Support Network

HomeDefectsLIN5-3641
Fixed

LIN5-3641 : fsl-t4xxx: boost can't build on the latest git tree

Created: Apr 8, 2013    Updated: Dec 19, 2017
Resolved Date: Apr 25, 2013
Found In Version: 5.0.1
Fix Version: 5.0.1.3
Severity: Severe
Applicable for: Wind River Linux 5
Component/s: BSP - Async

Description

Problem Description
====================== 
The boost can't build on the latest git tree.

Expected Behavior
====================== 

Observed Behavior
====================== 

Logs(Key error logs)
====================== 
/5.0.1.1/wrlinux-x/wrlinux/configure --enable-kernel=cgl 
--enable-rootfs=glibc_cgl --enable-jobs=12 --enable-board=fsl-t4xxx 
--enable-test=yes --with-sstate-dir=/5.0.1.1/sstate 
--with-rcpl-version=0
xxxx@pek-lpgbuild1:/5.0.1.1/fsl-t4xxx-cgl$ make -C build boost
make: Entering directory `/5.0.1.1/fsl-t4xxx-cgl/build'
Setting up host-cross and links
Setting up packages link
Creating export directory
Creating project properties
Loading cache: 100% 
|########################################################################################################################################################################| 
ETA:  00:00:00
Loaded 2708 entries from dependency cache.
Parsing recipes: 100% 
|######################################################################################################################################################################| 
Time: 00:00:00
Parsing of 1179 .bb files complete (1177 cached, 2 parsed). 2711 targets, 138 
skipped, 9 masked, 0 errors.
NOTE: Populating toolchain links in 
/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/sysroots/x86_64-linux/usr/bin/toolchain.
NOTE: Toolchain binaries pattern: 
/5.0.1.1/fsl-t4xxx-cgl/layers/wr-toolchain/4.6a-99/bin/powerpc-wrs-linux-gnu*

OE Build Configuration:
BB_VERSION        = "1.17.1"
TARGET_ARCH       = "powerpc"
TARGET_OS         = "linux"
MACHINE           = "fsl-t4xxx"
DISTRO            = "wrlinux"
DISTRO_VERSION    = "5.0.1.0"
TUNE_FEATURES     = "m32 fpu-hard e5500 e6500"
TARGET_FPU        = ""
wrlinux           = "WRLINUX_5_0_1_HEAD:99a02c627db848d4e1afab8bf4d96e82c05c2f9b"
wrlcompat         = "WRLINUX_5_0_1_HEAD:fbe5489adb3797689f7ba8e76c5c6f243ff67c47"
wr-toolchain      = "WRLINUX_5_0_1_HEAD:a3b89bfa6628b1029351876c422094044fd0745c"
meta              = "wr-20130220:dea7b57f6cc4bc7fa1018e8526e9931f04c063fb"
oe-core-dl        = "WRLINUX_5_0_1_HEAD:05a792f416b6b3e950bda1e12b3304a55fb11b10"
meta-downloads    = "WRLINUX_5_0_1_HEAD:fa0b1f5a26a3c086c49451e65f6ef77f61a0f74b"
wr-kernel         = "WRLINUX_5_0_1_HEAD:48671e0156e5bcf0d48179af36aba0ad0656bbe8"
fsl-t4xxx         = "WRLINUX_5_0_1_HEAD:d16358a87530e21d18b2e32bb829bfbf3f23a0a0"
wr-base           = "WRLINUX_5_0_1_HEAD:b1d3f35c343808e7e2a35e72e6f846f998f13837"
wr-features       = "WRLINUX_5_0_1_HEAD:b5cb8842fd5225fb285c3f6b4c0913446211829b"
wr-tools-profile  = "WRLINUX_5_0_1_HEAD:283c5cd956a9c485af832e74cd74282dce183b97"
wr-tools-debug    = "WRLINUX_5_0_1_HEAD:d6d50e2df6d9300a2a72ce300e1b158b142a298c"
meta-networking   = "wr-20130220:a33d7299539983e8abdb1fb049f40d9d1108a7df"
meta-webserver    = "wr-20130220:ff1fcb9719cdb30a552795e70e8f32bd2c878c15"
wr-prebuilts      = "WRLINUX_5_0_1_HEAD:c565bf4c33ef324a36cb3481f9d68495fe67dc28"
meta-selinux      = "wr-20130220:6faca962f005b3392991a25f20c3e5e9f2e66069"
wr-security       = "WRLINUX_5_0_1_HEAD:77f17cf0d55aa74e941df35a6b1108d3bd14fff6"
cgp               = "WRLINUX_5_0_1_HEAD:bed51c53a1b426b07f3585e8520fcc24f0e3ef65"
local             = "<unknown>:<unknown>"

NOTE: Resolving any missing task queue dependencies
NOTE: Preparing runqueue
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_system.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_thread.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_graph.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_regex.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_chrono.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_date_time.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_prg_exec_monitor.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_unit_test_framework.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_iostreams.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_signals.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_program_options.so.1.50.0'' 
strip command failed
ERROR: runstrip: ''ppce6500-wrswrap-linux-gnu-strip' --remove-section=.comment 
--remove-section=.note --strip-unneeded 
'/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/package/usr/lib/libboost_filesystem.so.1.50.0'' 
strip command failed
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-date-time/usr/lib/libboost_date_time.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-filesystem/usr/lib/libboost_filesystem.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-graph/usr/lib/libboost_graph.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-iostreams/usr/lib/libboost_iostreams.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-program-options/usr/lib/libboost_program_options.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-regex/usr/lib/libboost_regex.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-signals/usr/lib/libboost_signals.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-system/usr/lib/libboost_system.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-test/usr/lib/libboost_unit_test_framework.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-test/usr/lib/libboost_prg_exec_monitor.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost-thread/usr/lib/libboost_thread.so.1.50.0
ERROR: QA Issue: Architecture did not match (20 to 62) on 
/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/packages-split/boost/usr/lib/libboost_chrono.so.1.50.0
ERROR: QA run found fatal errors. Please consider fixing them.
ERROR: Function failed: do_package_qa
ERROR: Logfile of failure stored in: 
/5.0.1.1/fsl-t4xxx-cgl/bitbake_build/tmp/work/ppce6500-wrs-linux/boost-1.50.0-r3.1/temp/do_package/log.do_package.5491
ERROR: Task 11 
(/5.0.1.1/fsl-t4xxx-cgl/layers/oe-core/meta/recipes-support/boost/boost_1.50.0.bb, 
do_package) failed with exit code '1'
NOTE: Tasks Summary: Attempted 550 tasks of which 549 didn't need to be rerun 
and 1 failed.
No currently running tasks (550 of 723)

Summary: 1 task failed:
 
/5.0.1.1/fsl-t4xxx-cgl/layers/oe-core/meta/recipes-support/boost/boost_1.50.0.bb, 
do_package
Summary: There were 26 ERROR messages shown, returning a non-zero exit code.
make: *** [boost] Error 1
make: Leaving directory `/5.0.1.1/fsl-t4xxx-cgl/build'
xxxx@pek-lpgbuild1:/5.0.1.1/fsl-t4xxx-cgl$

Steps to Reproduce

1. /git/wrlinux-x/wrlinux/configure --enable-board=fsl-t4xxx --enable-kernel=cgl --enable-rootfs=glibc_cgl --enable-jobs=16 --enable-parallel-pkgbuilds=16 --with-sstate-dir=../sstate-cache/ 

2. make -C build boost

Other Downloads


Live chat
Online