Wind River Support Network

HomeDefectsLIN5-3472
Fixed

LIN5-3472 : Shared library version of libipsec not being built

Created: Jun 4, 2013    Updated: Dec 19, 2017
Resolved Date: Jun 27, 2013
Found In Version: 5.0.1
Fix Version: 5.0.1.5
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Only the static (.a) version of the ipsec library is being built.

The shared library should be built for all the usual reasons why shared libs are better.

Workaround

Use the static version.

Steps to Reproduce

$ configure --enable-board=qemux86-64 --enable-rootfs=glibc_cgl --enable-kernel=cgl
$ find export/dist/ -name 'libipsec*'
$ find bitbake_build/ -name 'libipsec*'
bitbake_build/tmp/sysroots/qemux86-64/usr/lib64/libipsec.la
bitbake_build/tmp/sysroots/qemux86-64/usr/lib64/libipsec.a
bitbake_build/tmp/sysroots/qemux86-64/usr/include/libipsec
...

Other Downloads


Live chat
Online