Wind River Support Network

HomeDefectsLIN5-23855
Fixed

LIN5-23855 : Security Advisory - git - CVE-2017-14867

Created: Oct 16, 2017    Updated: May 29, 2018
Resolved Date: Nov 27, 2017
Found In Version: 5.0.1.41
Fix Version: 5.0.1.42
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Git before 2.10.5, 2.11.x before 2.11.4, 2.12.x before 2.12.5, 2.13.x before 2.13.6, and 2.14.x before 2.14.2 uses unsafe Perl scripts to support subcommands such as cvsserver, which allows attackers to execute arbitrary OS commands via shell metacharacters in a module name. The vulnerable code is reachable via git-shell even without CVS support.

https://nvd.nist.gov/vuln/detail/CVE-2017-14867

Other Downloads


Live chat
Online