Wind River Support Network

HomeDefectsLIN5-23673
Fixed

LIN5-23673 : Security Advisory - linux - CVE-2017-14140

Created: Sep 14, 2017    Updated: May 29, 2018
Resolved Date: Oct 25, 2017
Found In Version: 5.0.1.41
Fix Version: 5.0.1.42
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Kernel

Description

The move_pages system call in mm/migrate.c in the Linux kernel before 4.12.9 doesn't check the effective uid of the target process, enabling a local attacker to learn the memory layout of a setuid executable despite ASLR.

https://nvd.nist.gov/vuln/detail/CVE-2017-14140

Steps to Reproduce

CONFIG_MIGRATION=y
CONFIG_NUMA=y

Other Downloads


Live chat
Online