Wind River Support Network

HomeDefectsLIN5-23580
Fixed

LIN5-23580 : Security Advisory - linux - CVE-2017-14106

Created: Sep 6, 2017    Updated: May 29, 2018
Resolved Date: Oct 15, 2017
Found In Version: 5.0.1.40
Fix Version: 5.0.1.42
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Kernel

Description

The tcp_disconnect function in net/ipv4/tcp.c in the Linux kernel before 4.12 allows local users to cause a denial of service (__tcp_select_window divide-by-zero error and system crash) by triggering a disconnect within a certain tcp_recvmsg code path.

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14106

Steps to Reproduce

CVE-2017-14106 Detail:
https://nvd.nist.gov/vuln/detail/CVE-2017-14106

Other Downloads


Live chat
Online