Wind River Support Network

HomeDefectsLIN5-23277
Fixed

LIN5-23277 : Security Advisory - php - CVE-2017-11144

Created: Jul 13, 2017    Updated: May 29, 2018
Resolved Date: Aug 16, 2017
Found In Version: 5.0.1.40
Fix Version: 5.0.1.41
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, the openssl extension PEM sealing code did not check the return value of the OpenSSL sealing function, which could lead to a crash of the PHP interpreter, related to an interpretation conflict for a negative number in ext/openssl/openssl.c, and an OpenSSL documentation omission.

https://nvd.nist.gov/vuln/detail/CVE-2017-11144

Other Downloads


Live chat
Online